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Amp up your Design Efficiency in 
Photoshop
with Dave Cross

Keyboard Shortcuts
One of the easiest ways to work more quickly and focus on the creative side is by using 
keyboard shortcuts. If you’re not a big shortcut user, start with selecting tools: tap the 
single letter associated with a tool. That’s much quicker than moving over to click on a 
tool.

Start with the main tools you use and gradually add more.
V = Move	 L = Lasso	 C = Crop	 T=Type	 B = Brush	 M = Marquee

Add in 
D = Default Colors	 X = Swap Foreground & Background
 
Customize Shortcuts
It’s also easier to remember and use shortcuts that you have created (rather than the ones 
allocated by someone at Adobe). If there are functions you use all the time that don’t 
have a shortcut, you can re-allocate one.
Go to Edit>Keyboard Shortcuts.
You can edit the shortcuts for application menus, panel menus and tools, so choose that 
first. Then find the command to which you want to apply your own shortcut and click 
beside it.

I suggest entering the shortcut you’d 
like to use and seeing to which com-
mand it is currently applied. In some 
cases you’ll note that the shortcut is 
used by some command you never 
use, so in that case you can accept the 
change.

In this example I wanted to create 
a keyboard shortcut for Add a Lay-
er Mask. I tried the shortcut Com-
mand-Shift-M (PC: Control-Shift-M) 
and it told me that shortcut was in use 
by Record Measurements. I never use 
that so I am perfectly fine with accept-
ing that change. 
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Here’s a quick list I put together of commands that I personally will “never” use and their 
shortcuts (and therefore ones I could assign to a different command)

Auto Tone: Shift Command L (PC: Shift Cntl L)
Auto Contrast: Option Shift Command L (PC: Alt Shift Cntl L)
Auto Color: Option Shift Command B (PC: Alt Shift Cntl B)
Print One Copy: Option Shift Command P (PC: Alt Shift Cntl P)
Here’s a secondary list of commands that I might (rarely) use, so I would also consider 
reassigning these shortcuts
Liquify: Shift Command X (PC: Shift Cntl X)
Save for Web & Devices: Option Shift Command S (PC: Alt Shift Cntl S)
File Info: Option Shift Command I (PC: Alt Shift Cntl I)
Color Balance: Command B (PC: Cntl B)
Vanishing Point: Option Command V (PC: Alt Cntl V)
Close & Go to Bridge: Shift Command W (PC: Shift Cntl W)
Disclaimer: Of course you need to evaluate which commands you do or do not use – 
these are just suggestions…..

Opacity Shortcut
Use the keyboard to change the Opacity setting. This works with both tool settings and 
Layer Opacity.

Rather than clicking on the Opacity setting, just tap the first number of the opacity you 
want: 1 for 10%, 20 for 20% etc. To get to 100% press 0. With Layers you can also tap 
00 for 0% Opacity – that turns out to be a great way to show and hide a layer without 
going anywhere near the Eye icons on the Layers panel.

When there’s a second option such as Flow (with tools) or Fill Opacity (with Layers), 
press SHIFT and the number to change that setting.

Brush Shortcuts
When working with brushes, making the trip up to the Options Bar to change the brush 
size is a waste of time. Use one of these methods:

• Use the [ and ] keys to decrease and increase the brush size
• Hold down Control and Option (PC: Right-click and Alt) and drag to the left 

and right to resize the brush
• Take advantage of the pressure sensitivity settings on a Wacom tablet

You can also change the hardness of a brush using shortcuts:
• Use SHIFT and the [ and ] keys to decrease and increase the hardness of  

brush
• Hold down Control and Option (PC: Right-click and Alt) and drag up and 

down to change the harness of a brush
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• To change to the next brush in the Brush Picker, press the . (period) key
• To change to the previous brush in the Brush Picker, press the , (comma) key

The Option/Alt Key
Remember this one and you’ll always find a way to save time. One of my former stu-
dents once referred to this as the “make better” key because it almost always adds some-
thing to a function. For example:

• In most dialog boxes, hold down Option/Alt to change the Cancel button to 
Reset

• When moving an object (layer, etc) hold down Option/Alt to make a copy 
rather than just moving it

• Hold down Option/Alt to Transform towards the center
• Hold down Option/Alt and click on the Eye icon beside a Layer to hide ev-

ery other layer. Click with Option/Alt again to show the again.
• Hold down Option/Alt and click on the Layer Mask thumbnail to view the 

Layer Mask

Path Shortcuts
Although there are separate tools for Add Anchor Point, Delete Anchor Point and Con-
vert Anchor Point, you don’t need them. With an existing path and the Pen tool, clicking 
on an existing point will delete it, clicking on the path will add an anchor point, and hold-
ing down Option/Alt will convert from a curved to a straight anchor point and vice versa.
Holding down Command/Control will temporary switch to the Direct Selection tool.

Layer Keyboard shortcuts
Speed up your work with layers by using these shortcuts…

Selecting Layers from the Image
With the Move tool active, hold down Command/Control to click on a layer in the image 
window to activate that layer in the Layers panel. Or Right-click to pop up a list of layers 
that are available at that location. (Naming your layers is important when using this 
shortcut).

Targeting Layers with Shortcuts
To activate the layer above or below the current layer in the layer stack, use these short-
cuts: Option-[(PC: Alt-[) targets the layer down one layer in the stack. Option-, (comma) 
(PC: Alt-,) targets the layer at the bottom of the stack. Option-. (period) (PC: Alt-.) tar-
gets the very top layer. These shortcuts are particularly useful when recording an action, 
so that the name of the layer is not recorded.

Moving Layers with Shortcuts
To move the active layer up or down in the layer stack, use these shortcuts: Command-[ (PC: 
Cntl-[) moves the layer down one layer in the stack. Command-Shift-[(PC: Cntl-Shift-[) 
moves the layer to the bottom of the stack (above the Background layer, or to the very bottom 
if there is no Background layer). Command-] (PC: Cntl-]) moves the layer up one layer in the 
stack. Command-Shift-] (PC: Cntl-Shift-[) moves the layer to the top of the stack
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Create a New Layer Below
To create a layer underneath a layer, Command (PC: Control) click on the new layer 
icon with the layer selected. The layer will automatically appear below the layer that you 
selected.

Hide a Layer Shortcut
As a quick way to hide and show a layer without moving over and clicking on the Eye 
icon beside the layer: press 00 to hide the layer and 0 to show the layer. 00 for 0% opaci-
ty, 0 for 100% opacity.

Layer and Mask Shortcuts
If you have a Layer with a Mask and you want to activate the Mask, press Command-\ 
(PC: Cntl -\). To activate the layer, press Command-2 (PC: Cntl -2).

Undo Layer Visibility
By default, clicking on the Eye icon to hide and show layers is not undoable. If you want 
to be able to use the Undo/Redo and Step Backward/Step Forward commands to show 
and hide layers you have to change one setting. In the History panel flyout menu, choose 
History Options and in the dialog check Make Layer Visibility Changes Undoable.

Lock Shortcuts
Press the / key to turn on and off the lock functions for layers – if nothing is locked it 
will toggle on and off lock transparency. If you had already turned on a lock (Lock image 
pixels, Lock position or Lock all) this shortcut will toggle on and off that lock.

Tool Presets
Most tools have settings that affect the way the tool operates. Rather than always having 
to remember to go through and check every setting before using a tool, you can save a 
preset. The process is pretty simple (the harder thing is to get in the habit of using these 
presets).

STEP ONE: Choose the settings for the tool. (With the Type tool it’s easiest to temporari-
ly create some type and format it to look the way you want).

STEP TWO: Click on the tool icon in the Options Bar to open the Tool Preset Picker

STEP THREE: Click on the new icon to give your preset a name 

NOTE: Although Photoshop 
prompts you to name the preset 
starting with the tool name, it’s 
really unnecessary since the tool 
icon will appear there. 
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Once you have saved some tool presets it’s simple to use 
them: pop up the Tool Preset Picker and choose the preset. I 
recommend having “Current Tool Only” checked so you only 
see the presets for the tool you’re using. 

REMEMBER: Choose the preset before using the tool – you 
cannot enter some type and then apply a preset. You must 
choose the preset first and then use the tool (hence the “PRE” 
part of the word preset). 

Hint: Consider making a tool preset for the “Normal” settings for each 
tool so it’s easy to get back to settings such as Normal Blend mode, 100% 
Opacity etc.

Bonus Tip:
Show the Tool Presets panel and use it to switch to a tool and apply the 
settings from the preset.

Other Presets
A very effective way to think of presets is as a starting point: you can al-
ways change settings etc. but starting with a preset can save you time. For 
example, if you often apply an “S-curve” in Curves, create a preset for it 
– then you can always tweak it on an image-by-image basis.

To do this, add a Curves Adjustment Layer and make an S-curve. Use the 
flyout menu to Save a Curves Preset.
Name the preset and save it into the prompted folder.

From then on when you add a Curves Adjustment Layer, pick the preset 
you created, and tweak if necessary.
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Add Canvas with the Crop Tool
When you need extra canvas and it doesn’t have 
to be a specific numeric amount, instead of using 
the Canvas Size command, use the Crop tool. 
Click on the Crop tool and then drag any handle 
outside the current canvas size. As soon as you 
press Enter, canvas will be added – transparent 
pixels if the layer is unlocked (or a Smart Object) 
or in the Background color. 

To fill in the extra canvas you have a couple of 
options, and it will depend on the background. 
For a mostly solid background color like this ex-
ample, select as much of the existing background 
as you can and copy it to a new layer. Then use 
Edit>Content-Aware Scale to fill in the extra 
space.

If the background has texture, try using the 
Content-Aware Move tool with the Mode set to 
Extend. Add a blank layer and make sure Sample 
All Layers is checked. Again select as much of 
the existing background as you can and then drag 
to fill in the extra space.

Simple Actions
Not every action needs to include multiple steps - you can also create a 
series of single-step actions. Just record individual operations, especially 
ones that require going to sub-menus or inside dialog boxes.

One example: record a one-step action that chooses a commonly used 
tool preset.

Then you can use the Actions panel flyout menu to switch to Button 
Mode – now you have a series of one-click actions.

You can also record an action that plays a series of these single actions. 

Blend If 
I talk about this function in just above every Photoshop class I teach because I think is 
just a valuable technique. Having said that, it doesn’t always work the way you want, but 
it’s certainly worth trying.
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In this example I want to blend a texture with an underlying photo. 
Just changing the Blend Mode along didn’t work, and I didn’t want 
to have to do a lot of masking. So  instead I double-clicked to the 
right of the name of the top layer, to open the Layer Style dialog.

In the Blend If section I experimented with the 2 
sliders: “This Layer” is my texture overlay and 
“Underlying Layer” is the flower photo.

To get a better result, hold down Option/Alt (there 
it is again) to split the triangle into two halves. 
After 20 seconds I got this result [below].

It’s important to 
note that both 
layers are Camera 
Raw Smart Objects 
which means I can 
continue to edit 
them. In the image 
below I changed the 
texture to Grayscale 
in ACR.
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Layer Styles
When most people think of Layer styles they probably think about Stroke, Drop Shadow, 
Bevel and Emboss etc. There is so much more to Layer Styles! And you can apply these 
less-commonly-thought-of styles very easily.

These functions are in-
cluded in Layer Styles 
and can be copied and 
pasted or saved (more 
on that in a minute):
Blend Modes
Opacity
Fill Opacity
Knockout
Blend If Sliders

NOTE: Although you 
can drag and drop 
while holding down 
Option/Alt to copy 
Layer Styles from one 
layer to another, these 
functions will not copy

To copy everything you must either use Copy Layer Style/Paste Layer Style or create a 
New Style.

Layer Comps
One of the most powerful ways to experiment in Photoshop is to create multiple layers 
and then try various combinations: hiding, showing and moving different layers around. 
You can make this process simple and efficient – and readily accessible – by using Layer 
Comps.

The basic idea of a layer comp is to capture the current status 
of the Layers panel: what layers are visible, where they’re 
positioned and what layer styles (if any) are applied. By 
creating a series of Layer Comps you can quickly and easily 
switch between different layer combinations.

Typically you’d do this after you have created a series of 
layers, including different choices of sizes, fonts etc.
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Layer Comps “remember” the visibility, position and appearance of the layers, but not 
the content. In other words, you cannot change the size of an object, the typeface of a 
type layer or anything like that without it affecting all layer comps. If you want to have 
one large logo and a smaller version, you’d have to duplicate the layer and use Free 
Transform to make the second logo smaller – then show or hide the appropriate version. 

By the same token, if you want the option to choose between white text and black text, 
you’ll have to make 2 versions of the type layer, one white and one black.

Once you have a list of comps you can easily browse 
through them by clicking on the arrows, or look at a 
specific comp by clicking to the left of the comp you 
wish to view.

Layer Comps are “stored” in a psd file, adding very 
little to your file size, and are a great alternative to 
creating separate files.

And remember, Layer Comps can include Layer 
Styles, which as we saw also means Opacity, Blend If 
sliders etc.

Smart Objects
The best way I can think of to describe a Smart Object is as a container – a special, mag-
ical container! Think of it this way: when you convert a layer to a Smart Object you are 
putting the contents of that layer into a container. At any time you can double-click on 
the Smart Object to view (in a separate document) the contents of the container.

When you apply a filter to the Smart Object, the container shows the effects of the fil-
ter(s), but the contents remain unchanged. This means you can always edit or remove the 
filter, even after saving the document.

Here’s the magical part of the container: you can scale and rotate the container but once 
again, you can always get back to the original contents, even scaling them back to their 
original size.

As we’ll see, Smart Objects offer some major advantages including:

• the ability to apply editable filters
• the creation of a editable version of Camera Raw
• the option to create “templates” 
• the option to apply filters to text while keeping the text editable



© dave cross, 2019

PHOTOSHOP WORLD 2019 - NOTES

Page 10

There are a number of ways to create a Smart Object from one or more layers. After se-
lecting the layer(s), use one of these methods:

1. Convert to Smart Object
This option is available by Control-clicking (PC: Right-clicking) beside the layer, from 
the Layers panel flyout menu, or from the Layer menu)

2. Convert for Smart Filters
Under the Filter menu, choose Convert for Smart Filters.

You can also create a Smart Object as you open a file, by using File>Open as Smart Ob-
ject rather than File>Open.

If you have a document open and would like to create a Smart Object in the document 
from another file, use File>Place. When you place a file into the document it automati-
cally is added as a Smart Object. In addition, if you drag in from a Library it will create a 
Smart Object.

Camera Raw and Lightroom both have an option to work with Photoshop as Smart Ob-
jects.

Smart “Templates”
The word “template” doesn’t appear anywhere in Photoshop. Unlike some applications 
that have a “Save as Template” command, in Photoshop when you save as a PSD file that 
contains Smart Objects, it acts like a template. I use the term template to point out the 
possibilities of using Smart Objects in this way.

Here’s an example that you set up once, and then use repeatedly to show business card 
designs.

Start with 
a photo of 
blank cards.

Add a new layer and add a selection in a 3.5 x 2 ratio and fill it with a color. This will be 
your placeholder for all the cards.
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Convert that layer to a Smart Object. 

Duplicate that Smart Object until you 
have enough copies for each of the 
cards.

Transform and mask each copy to 
match up with the cards.

Save as a PSD. Now you have your 
template*.

Double-click on any one of the Smart 
Objects. 

Place the card design artwork into the 
contents document, sizing it to fit.

Save the contents document and when you 
go back to the main document, all the Smart 
Objects will update.

* Saving as a PSD does not create a true 
template. But if you rename that file to 
.psdt instead of .psd, it will become a 
template and an untitled copy will open.
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Data Driven Graphics (Variables)

When you have to create a series of graphics where some elements stay the same and 
some elements change (e.g. name, company, title etc), Variable are the way to go. (Think 
mail merge for graphics).

First we create a typical Photoshop document using layers. It’s important to name your 
layers with a helpful name. In this document we’re going to create what amounts to 
“placeholders”: layers that will be replaced with data that varies with each layout.

In this example I‘ve created media passes for photographers at an event. 
Each photographer would provide their photo, 
their name and who they work for, so 3 layers 
would change while the remainder stay the 
same. When laying out the artwork for the pass 
I create a layer for the photo (including stroke 
and drop shadow layer styles) and two type 
layers.

Hint: when setting the type, use a very long 
name (e.g. Matthew J. Kloskowski) and adjust 
the point size to make sure it fits – if that long 
name fits, all the rest should. 

Once your document is complete (and saved) you need to 
tell Photoshop which layers are the variable ones. You do 
this from Image>Variable>Define. In the dialog go through 
the list of layers and assign a variable to the layers that 
will change. For example, my photo placeholder (called 
photo – remember the hint about naming your layers?) will 
be replaced with each person’s photo.  I clicked on Pixel 
Replacement and named that variable “photo”. What you 
call the variable isn’t important but later you do have to 
remember what label you used.

Next you create a text file that contains two things: the 
variable by name on the first line, and then one line per 
person that contains their name, their company name 
and the name of the photo file. Save that file as a plain 
text file.
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All the files go into the same folder: the text file 
along with each person’s photo (making sure the 
file names match up with the text file).

Now go back to the document, this time using 
Image>Variable>Data Sets. Click on the Import button 
and navigate to your text file. As soon as you turn on the 
Preview you should see the first photo, name and company 
displayed in your document. You can scroll through (and 
Preview) all the records in your text file by clicking on the 
small arrows to the right of the Data Set field.

Note: when you click OK, your document will return to 
its “placeholder” look. The final step to create the actual 
files is found under File>Export>Data Sets as Files. In the 
dialog, select a folder to put the files and set up a naming 
system if you like. Click OK and all of new documents will 
be created, one for each line (each of the people) in your 
text file.

It’s important to note that the resulting files are layered documents, meaning 
that you can  “tweak” the results if necessary. To create flattened jpegs from the 
layered files, use Image Processor to save a copy as jpeg.

Needless to say, setting up Variables 
doesn’t make sense if you only need 
to create 2 or 3 customized versions of 
a document. Where Variables shine is 
when you have a situation where some 
photos and text change and you have to 
create 50 or 100 or 500 versions. Then 
the small amount of setup time will save 
you hours and hours of manual labor.
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For 32 years Dave Cross has been helping photographers and creative professionals get the most out of their 
Adobe software. Since 1987, Dave has taught Photoshop, Illustrator and InDesign to thousands of users around 
the world. He has a Bachelor of Education, is an Adobe Certified Instructor, a Certified Technical Trainer and in 
2017 and 2018 was named an Adobe MAX Master Instructor. Dave has taught for Adobe, at Photoshop World, 
Creative Pro Week, Imaging USA and at numerous corporate locations. Dave has written many articles and 
multiple books, and has taught many online courses for Kelby Training, Creative Live and now through his own 
training site LearningPhotoshop.CC.

Over the last 20 years, Dave has taught Photoshop in every state in the United States, throughout Canada and in 
Europe, consistently earning rave reviews. In 2009 Dave was inducted into the Photoshop Hall of Fame.


