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Using Illustrator with Photoshop
with Dave Cross

From lllustrator to Photoshop

Import PDF

. Select: Page Options
l. F11e>open O Pages Images 3D Name: swans-bl.ai
When you open an Illustrator file in Photoshop you = Crop To:  Bounding Box -
will see a dialog box with options for sizing, mode, i AT
resolution etc. Imagine this dialog is asking you “at mage Sizes & 35M

. . Width: 4.601 Inches

what resolution do you want to Rasterize the Illustrator aighe: (2750 nehes
artwork?” That should remind you that using the Open Constrain Proportions

Resolution: 300 Pixels/Inch

command, you basically have one opportunity to get
the file the size that you want — and that rasterizing
means there is no longer a link back to the original

Mode: U.S. Web Coated (SW... v

Bit Depth: 8bit v

Suppress Warnings

graphlc ' 1 of 1 page(s) selected Open In Reverse Order

Thumbnail Size: Small v Cancal

Open As Smart Object

2. File>Place Linked

Placing an Illustrator file into an existing Photoshop
document means that you will be creating a link back
to the original file. Note that the dialog is called “Open
as Smart Object” (although it should really be called
Open as Vector Smart Object).

Once the file is placed, you can double-click on the
Photoshop thumbnail to open and edit the original
artwork in Illustrator.

Keep in mind that if you edit the Illustrator artwork
for this Photoshop document, any other document that
uses this artwork will be affected. Also, if you move
the Photoshop document you would need to move the
Ilustrator file as well to preserve the link. Trembrel iz | Smal_~ Cancel

Select: Options

O Page Crop To: Bounding Box v

3. File>Place Embedded
The result is the same as Place Linked, (including the ability to edit the
original in Illustrator), except you do not need to include the Illustrator file Paste

if you were to move the file. Paste As:

Smart Object
4. Copy and Paste

If you Copy in Illustrator and then switch to a Photoshop document and
Paste, you’ll see these options in the Paste dialog. Paste as Smart Object
creates a link back to Illustrator that’s similar to Place Linked — except that Shape Layer
the artwork you’d be editing in Illustrator is not the original artwork.
Paste as Pixels means Rasterize.

O Pixels

Path
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Paste as Path would be used if you wanted to paste just the path, without any fill or
stroke, to then do some Photoshop operation using the Path (this is perhaps the least com-
mon use).

Paste as a Shape Layer can be used to then create a Custom Shape in Photoshop. To do
this, after pasting select the shape with the Selection tool and then use Edit>Define Cus-
tom Shape.

5. Library

Drag selected artwork in Illustrator into a Library, and then in Photoshop drag from that
Library into a document. The result acts similar to a Vector Smart Object, except if you
edit and save in Illustrator, it will also update the graphic in the Library.

If you wish to take a graphic from a Library and “break the link” to the Library, hold
down Option (PC: Alt) when you drag from the Library into the document.

Here are the different icons that appear

on the Layer thumbnail depending on Place Embedded q{@@y@x swans-bl

which method you use. (Note there is ~SWANS

no icon on the Paste as Pixels layer m =

thumbnail since there is no option to i

edit the original once it is rasterized). Place Linked AF‘J‘{{)‘}: e

e R

Also, double-clicking on the Shape lay-

er opens the Color Picker. There is no

option to edit the original artwork. Drag from Library with
Option/Alt

Artwork 7

Drag from Library e Artwork 7

Paste as Shape Layer

Paste as Pixels

Paste as Smart Object ) Vector Smart Object
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6. Export as a PSD file

This one is more unusual and is intended for times when ° Export
you’ve started a document in Illustrator and want to con- save As: vite.0s -
tinue editing in Photoshop — in layers. oo
In Illustrator use File>Export>Export As. = =0 ®- m AP > Q
Change the Format to Photoshop (psd) R o SR Uegrace- )| (Ceern bore=)
#; Applications
In the Export Options dialog change the Color Model to g s,
CMYK*, choose the Resolution and check Write Layers. @ creative Cloud..
icloud
Photoshop Export Options g ::;::1:“"9 o
M Documents
Color Model: CMYK Format: Photoshop (psd)
Use Artboards Ol ~JRange:
Resolution: Medium (150 ppi) S —
Options
O Flat Image *Even if you need an RGB file, start with
Write Layers CMYK or else you will be unable to
Preserve Text Editability export the layers

Maximum Editability

Anti-aliasing: Type Optimized (Hinted)

Embed ICC Profile: U.S. Web Coated (SWOP) v2

together with ...ir wedding day

14, JULY, 2020 AT 12 NOON

Here’s a portion of the Layers panel in Photoshop after opening the re-
sulting psd file. Generally it does a very good job of separating the Type .
layers . reception to follow
The only disadvantage of this method is the graphic elements are raster-
ized using the setting you chose in the Export Options dialog, so you no
longer have any options of editing the original artwork in Illustrator.

THE VENUE 12...Y, AL, 22000

Flowers Line Art + Divider

Color Accent

Background
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Examples E

Artistic Texi Dot Pattern Mad Science

1. Symbols

[llustrator doesn’t have much in the way of “clip art”, but you can use
artwork found in the Symbol Libraries. Under the Window menu use
Symbol Libraries and open one of the 25+ libraries. Click and drag one
of the symbols into a document.

You can either use the symbol as is [left], or use Object>Expand to ac-
cess the elements that make up the design and edit accordingly [right].
(Then use one of the methods for moving the design into Photoshop).

There are all kinds of options in the Symbol libraries, from complete
graphics to design elements. In this example, I used 2 different elements
from the Dot Pattern Vector Pack to create a design in Illustrator.

After pasting into Photoshop, I rotated the
graphic and used it as a Clipping Mask.
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2. Brushes X

Artistic_ChalkCharcoalPencil

Look inside the Brush Libraries to find some interesting design elements
that can be used in Photoshop as borders, edges, or even to make a Photo-
shop brush. In this example I dragged a brush from the Artistic ChalkChar-
coalPencil Brush Library.

You can also make a shape and apply
the Brush to the stroke of the object.

In this example I copied and past-
ed this artwork to Photoshop (as a
Smart Object so I could tweak the
results) and then used Edit>Define
Brush to make this into a Photoshop
brush [below].

Brush Name

C Name: stain
» Cancel

913

In this example I created a rectangle in Illustrator
and used a couple of the above brushes as a stroke.

Again, this was copied and pasted in Photoshop to
use as a Clipping Mask.
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3. “Hidden” Artwork

The latest version of Illustrator CC has some “hidden” artwork, some of which might be
useful for Photoshop projects. To access it, use File>New and then click on the Art &
Illustration tab at the top.

@ New Document

Art & Illustration

TEMPLATES (15)

Circular Water Texture
Overlays Set

By Collective Offset

Adobe Stock

A set of assorted water textures for adding
aquatic effects to your creative work.

Grunge Textures Set I Watercolor Vision Patterns Set

Paint Brush Strokes Patterns Set Circular Water Texture Overlays ... 33 Hologram Gradient Set

Download

You’ll see a series of templates that are from Adobe Stock, but provided for free. Down-
load the file, open it in Illustrator and use one of the methods to move the artwork (or
portions thereof) into Photoshop.

Here part of the Grunge Textures
set was used to create a Clipping

O Effects

© Drop Shadow

Layer 2
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4. Patterns

Unfortunately you cannot take Illustrator patterns and use them directly in
Photoshop (or vice versa), but with a bit of work you can (often) take advan-
tage of Illustrator patterns to make Photoshop Patterns.

Vonster Patterns

Drag a pattern swatch from an Illustrator Pattern library into a document.

Change to Outline View (Command/Control-Y) to see

where the “bounding box” is that defines the pattern, With N\ Q j) I/

the Direct Selection tool, Option/Alt click on the rectangle g} é L7 A YS

and then Copy and Paste in Front. : ﬁ& B
Z

A\ i E Iy § ; )

Ly Hey

Use the Shape Builder tool with Option/Alt held down to drag over the areas outside '
the rectangle. You may want to zoom in closer to make sure that you’ve removed
every area outside the rectangle.

V/(

P

4

Now switch back to normal (Preview) view.
Select all.

1

5C

Select all and copy.

Go to Photoshop and create a New document. It should automatically create the size
based on the information in the clipboard (that you copied).

Paste as a Smart Object and press Enter. kv

Go to Edit>Define Pattern. Pattern Name

% Name: red design

Cancel

In Photoshop apply the
) pattern using the Pattern
Overlay Layer Style.
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From Photoshop to lllustrator

For the first methods, it’s important to remember that the pixels from Photoshop can be
used as part of a design, but will remain pixels. You can scale everything else up without
losing quality but the Photoshop elements may lose quality depending on the resolution

you started with.

1. Copy and Paste

In Photoshop select a photo (or an area of a photo), Copy, switch to Illustrator and Paste
onto a document. There is no connection between the original photo and the pasted infor-

mation.

2. Place

Use File>Place and find the Photoshop file. Unless the document contains Layer Comps
(see below) it will appear as a single image. To edit the original Photoshop document,
hold down Command and Option (PC: Control and Alt) and double-click on the placed
image. Save changes in Photoshop and when you return to Illustrator you’ll see a dialog
about missing or modified files. Click OK to update the placed file.

3. Open

You can Open a PSD file in Illustrator, but the results will vary depending on the contents
of the file. For example, a layered file with shape layers and type layers will turn into

editable paths and type in Illustrator.

You'’ll see this Import Options dialog with the option to Convert Layers to
Objects and “make text editable where possible”.

Here the shape layer and
type layers are all editable,
and transferred nicely.

If text does not come across
properly you could choose
to Flatten Layers to a Sin-
gle Image.

Note: a PSD file without
layers will open as a single
image much like copying
and pasting.

If your Photoshop document contains Layer Comps you can choose be-
tween the comps before opening (or placing) the document. Later if you’d
like to switch to another comp you have to relink the file (in the Links

panel).
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Photoshop Import Options

Preview Comments

Show Preview

Options

Convert Layers to Objects
Make text editable where possible

O Flatten Layers to a Single Image
Preserves text appearance

[ Import Hidden Layers

Photoshop Import Options

Layer Comp: | all

Preview Comments

Show Preview
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Note: working with jpeg files works the same as a PSD without layers.

4. Paths
You can use Photoshop Custom Shapes as basic artwork in Illustrator. Change the
Options Bar setting to Path and drag out the shape. Copy, switch to Illustrator and
Paste.

faste Ogtions In the Paste Options dialog choose

Compound Path (fully editable).
Paste As

Compound Shape (fully editable)
Note: the pasted shape will have no

stroke and no fill, so if you deselect it,
it will “disappear”.

(O Compound Path (faster)

For 32 years Dave Cross has been helping photographers and creative professionals get the most out of their
Adobe software. Since 1987, Dave has taught Photoshop, Illustrator and InDesign to thousands of users around
the world. He has a Bachelor of Education, is an Adobe Certified Instructor, a Certified Technical Trainer and in
2017 and 2018 was named an Adobe MAX Master Instructor. Dave has taught for Adobe, at Photoshop World,
Creative Pro Week, Imaging USA and at numerous corporate locations. Dave has written many articles and
multiple books, and has taught many online courses for Kelby Training, Creative Live and now through his own
traning site LearningPhotoshop.CC,.

Over the last 20 years, Dave has taught Photoshop in every state in the United States, throughout Canada and in
Europe, consistently earning rave reviews. In 2009 Dave was inducted into the Photoshop Hall of Fame.
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